Programadora web y fan incondicional del Doctor

Entradas etiquetadas como ‘php5’

Actualizar osCommerce 2.2MS2 para funcionar en PHP5

Hay veces que actualizas la versión de una web por gusto, y otras definitivamente no. En otra ocasión contaré por qué me he visto obligada a migrar un osCommerce 2.2MS2 a un servidor con PHP 5.3 (en realidad funcionará para PHP 5.0 o superior). Ahora es momento de ir al tajo, al quid de  la cuestión: ¿qué hago cuándo no funciona nada?

Visito el dominio, tengo un pantallazo en blanco y este maldito mensaje de error: Failed opening required ‘includes/languages/.php

Problema real: tu osCommerce no entiende cómo crear sesiones, ni cuáles son las id de los diferentes idiomas, ni por dónde le pega el viento.

Solución: seguir esta actualización de 87 pasos (nada más y nada menos) http://addons.oscommerce.com/info/6654

Siguiente error: Por mucho que cabio los permisos de escritura de los archivos configure.php, me sigue apareciendo el maldito aviso. Debe ser cosa del PHP5. Me cago en el puto PHP5 ya, hombre.

Solución: Si no nos deja cambiar manualmente a 644 o a 444, pues le obligamos. Aquí las instrucciones Agujero de Gusano – Osc permisos configure php

Después de todo este esfuerzo, y del que vino antes de este (primero intenté actualizar a osc2.3 pero no funcionó), me planteo si no es mejor instalar un osc2.3 limpio, ponerle un tema bonito y meterle el contenido. Supongo que si merece la pena o no, dependerá de cada caso.

Buenas noches y buena suerte!